A New version of PowerCLI has been released today to support the recent releases of vSphere 6.7/ vSAN 6.7 and NSX-T 2.1.

It includes the 20th module  vmware.vim that we can use to work with API’s in VMware on AWS so that should be something to look into later.

If like me and run via a Linux Powershell then to update the  PowerCLI modules all you need to do is the following (via the powershell prompt):

1
Update-Module VMware.PowerCLI

Heres a link to the VMware article that talks about some of the new features:

New Release: VMware PowerCLI 10.1.0